PDF printer won't accept jobs from non-admin users

Hi! This is my last resource since I've looked everywhere in this forum and tried some solutions.

I have a simple Active Directory setup where I installed PDFCreator, I want to share a printer which saves PDFs to a common directory which PDFCreator can write. The thing is that unless the user sending the print job is an administrator, the printer won't finish receiving the print job. My print queue gets stuck like this: http://i.imgur.com/x6Nncu2.png.

Here's what I've tried

1. Reinstalling PDFCreator
2. Setting permissions in the spooler directory, in my case C:\\DOCUME~1\\ADMINI~1\\LOCALS~1\\Temp\\7\\PDFCreator\\Spooler
3. Make the print user member of the Print Operators group
4. Verified that the user can print to other printers, he can.
5. Checked the PDFCreator log, but since the job won't even finish loading, PDFCreator doesn't register anything to the log, unlike the jobs sent from admin users.
6. Check the system events for errors, no avail.

I don't know what else to do, any help would be appreciated.

Here's a link to my SetupLog.txt since I can't paste it here without hitting the char limit: http://pastebin.com/c1FqazB6


Ok answering my own question:

The print spooler’s directory is %SystemRoot%\Temp\PDFCreator\Spool, not the one in the “Documents and Settings” folder. I created a new group in the AD, made my printing users part of that group which have writing permissions to that folder.

It now works like a charm.