PDFArchitect can't be opened by PDFCreator


I wanted to use a older and smaller version of PDFArchitect (as I've always used in my home PC), but doesn't matter what I do, I can't make PDFCreator let a just created pdf file be automatically opened with PDFArchitect.
The option for it in PDFCreator is always greyed-out, no matter what.

I've already tested from PDFArchitect until PDFArchitect-0_5_6_675

and also, from PDFCreator-1_7_0 until PDFCreator-1_7_3

I'm using a Windows 7 64bit pc  (my home pc, where this things are working just fine btw, has a Win7 32bit).

Hope that someone can comment on that, since solving this issue is important for me. Feel free to ask more info if needed.


the checkbox was most likely added with the release of PDF Architect 1 and therefore only checks the registry key where PDF Architect 1 or newer gets registered. A workarround could be setting PDF Architect as default application for opening PDFs, if this is an option for you.

best regards,

Hi Robin, thank you for your attention,

I went back to my home PC (win7 32bit) and saw that the option there was not greyed-out, and was properly selected. Also, the default application for opening PDFs there is Foxit Reader, and even so, PDF Architect opens the PDF after it has been created in PDFCreator.

The software’s versions there are as follows:

PDFCreator v. 1.7.0

So, seems like this old versions should work, and not be just linked together based on PDF Architect being the default PDF app or not… (btw, I don’t know how to set this versions of PDF Architect as default apps, I actually think it’s not even possible…)

I thought that the problem could be folder/files location that could be different in win64 compared to win32, but after doing some tests, I don’t know if it would be the case…

is it a incompatibility with win64 systems themselves?

Hope you have some idea about this things :stuck_out_tongue: …thank you

Hey, please don’t let the topic die if there’s something that can be done about the issue.

I’m still interested in fixing this, since I always used this softwares…  Hope that there’s something that can be done still.


I am not sure if this will be fixed since the PDF Architect 0.x versions are so outdated, but it should for possible to set them as default application for opening PDFs, as you can do this with any executable. Right Click onto any PDF, select open with->choose default application and then ignore the list of displayed applications and use the “browse” button instead. Now navigate to the PDf Architect.exe and make sure the checkbox to “always use this application” is checked.

best regards,

Ok Robin, I guess that’s what I’ll do, since I couldn’t think of anything else (still weird that it works fine at my 32bit pc though :S ).

Thank you for your time and help.