PDFCreator 0.9.9 released

We are happy to announce the release of PDFCreator 0.9.9.

This release adds two major features. You can define printing profiles to store settings for a certain purpose and load them when required. Additionally, you can have multiple PDFCreator printers that by default use one of the profiles. For example, this can be used to automatically save invoices in a certain directory when printed to an invoice printer, while have another regular PDFCreator printer. There are also some smaller fixes as well as progress in the cClose Bug of the COM interface, which we hope is solved now.

I have not had a chance to download and test yet.  Do you know if you all we able to fix the page numbering issue with total page numbers in Excel

As mentioned in

"Excel Page Numbering and Margins Issue and New Release?"






I just downloaded version 0.9.9 and everything broke.  When I tried to run PDFCreator after the upgrade, it acted as though it were printing to a printer and no PDF was created.

So I thought I'd uninstall PDFCreator and start over.  Nope.  The uninstall isn't clean.  It leaves a gsdll32.dll file in the PDF folder.  I can't delete it.  And the new install can't overwrite it.

So I'm stuck without a working PDFCreator!  Can you help.



please try rebooting between the uninstalls. If that alone does not work, please follow this FAQ entry to override that PDFCreator is already installed:


kind regards,


0.9.9 does not work for me, revert to 0.9.8

I happily used 0.9.8 for more than a year. Today 5 jan PDFCreator signaled me that version 0.9.9 was available.

So I uninstall 0.9.8

Then successfully(so said) 0.9.9

Now when I print a MS-Word 2000 document version 0.9.9 ask for name, location, I see the tiny pages icon on right corner as if printing but no file is created! To check I search my all HDD.

OS: Win98SE

MS-Office 2000

If you need further technical info I can post Belarc Advisor info (CPU, packages...)


0.9.9 seems to ignore the /UseINI switch and uses the Registry. I've tested this more than once on XPSP3. Anyone else with this problem?


Sorry, the old ini-mode is not supported anymore. This has something to do with the new profiles feature.

v0.9.9 works fine for me in Server mode - thanks for the cool new feature to allow multiple printers and profiles. It works better than v0.9.8 on Win Server 2003 because it's no longer needed to make an exception to Data Execution Prevention (DEP) for PDFCreator.

However, a second problem still remains: if nobody is logged into the server locally, no PDF file will be created until someone logs in!

looks like the Excel total page number issue was not fixed.

6 page Excel file, when I print it to a printer it says "6 total pages" When i print to PDFCreator it says 12 total pages.




I really like this soft that I use for several years.

I have a bug to report. I suppose it's not the right place to do it, but I don't know this right place ;-)

I use the PDF/A option to create long term pdf from word documents, and I have one document in witch the pdf opens with a warning that it was not able to open or create the LucidaSans font (even though Word recognize it): as a result all the characters in this font are not printed.

I installed the 9.0.9 release but it was not fixed.

Can you help me?


Lot of crashes while using profiles... while using water marks...

Hope it will be corrected soon

I installed version 0.9.9 and it looked OK.  I got the print popup and selected PDFCreator and nothing happened.

I uninstalled it (again).  But it leaves a remnant in the program folder and I can't delete it.

How do I totally remove it?


I’ve setuped 0.9.9 and there is no Russian language. 0.9.8 has Russian.

Hi, I'm Slovenian translator since version 0.8.1 RC6 but unfortunately didn't receive any notification about releasing 0.9.9 version as for previous versions. For years I checked this forum regularly but now even a few months can pass between my visits. So I missed it online too. I was sad and happy at the same time when PDFcreator notify me about new version. Glad because of success of this great program but sad because of lack in Slovenian translation in program itself and even in setup.

Now I updated my translation but unfortunately didn't find any link to upload it. Please let me know where is it. Will the version 0.9.9 be updated with missed translation(s)?

What I found that this link is broken on the end of translations page: http://en.pdfforge.org/node/72

I found this thread about the culprit just now. Other "missed" translators should be contacted also. It is important that such a good program maintain good community including translators.

Thanks Philip, other authors, translators and contributors for great program. Be well,















 will it work with MS Office 2010?


The previous version (0.9.8) generated a blank pdf from any MS Office 2010 product. :/

PDFCreator is very very good, but where RUSSIAN language in ver.0.9.9??

Is this version of PDFCreator can set the print presets properties of the pdf files like page scaling, duplex mode, paper source by page size ??

Can you tell me what is fixed in 0.9.9., s.a. "Fixed some minor bugs".?

Greatings and a happy new year,



Hi Philip,

I'm having some trouble with PDFCreator 0.9.9 under Windows Vista. The problem seems to be related to inconsistencies in the location of temp folders, and is Vista-specific. I don't encounter any trouble when running the same operations with the same version of PDFCreator on an XP machine.

Initially I found PDFCreator putting its temp files for spooling in "C:\\Program Files\\PDFCreator\\Temp\\PDFCreatorSpool" - not a good place for temp files under Vista. It turned out that when I uninstalled the previous version of PDFCreator, I needed to say "yes" when it asked whether to remove all the previous settings. It had left an old setting in the registry which was pointing to this temp folder under "C:\\Program Files". This had led to a problem that I've seen reported by someone else, where print jobs would correctly show up in the PDF Print Monitor's queue, and would successfully be processed, but could never be deleted. They'd just continue to accumulate, PDFCreator would run over and over again trying to process them, and the only way to close PDFCreator was by terminating it from the Task Manager.

After uninstalling PDFCreator, letting it remove all settings, and reinstalling, this particular problem was resolved. Now the temp files for spooling show up in a better place, at C:\\Users\\{username}\\AppData\\Local\\Temp\\PDFCreator\\PDFCreatorSpool

I had hoped that this would resolve all the problems, but the following symptoms remain:

1) When I print to PDFCreator, the PDFCreator program fails to start automatically. The spooler files do appear as expected in C:\\Users\\{username}\\AppData\\Local\\Temp\\PDFCreator\\PDFCreatorSpool. One odd thing that may be related to the failure is that a "PDFCreator\\Temp" folder appears in "C:\\Users\\Admin\\AppData\\Local\\VirtualStore\\Program Files". This would indicate that PDFCreator is still trying to put a temp folder under "C:\\Program Files\\PDFCreator". Maybe some PDFCreator process is failing to check the registry for the correct temp folder location.

2) In order to proceed with the print job I can start PDFCreator manually. But when I do this it doesn't show the document in the queue. And if the "PDFCreator\\Temp" folder in VirtualStore has been previously removed, it reappears. So here again some PDFCreator process is trying to put a temp folder in the wrong place. Maybe the reason it doesn't show the document in the queue is that it isn't looking in C:\\Users\\{username}\\AppData\\Local\\Temp\\PDFCreator\\PDFCreatorSpool, where the registry setting would tell it to look.

3) Finally, if I close PDFCreator and this time restart it with admin privileges, it now correctly shows the document in the queue and successfully processes it. This time nothing new shows up in VirtualStore. So when running as admin, the correct temp folder location is retrieved from the registry and used.

So I can now get PDFCreator to work, but it's not functioning as intended - lots of manual intervention is required. Any ideas on how to get it to start automatically as it does under XP, and function correctly without admin privileges?

Allan J.