PDFCreator 2.4.1 Setup repeatedly demands system restart

I am trying to install the PDFCreator update for Windows 7/Firefox 50.1.0.
I uninstalled PDFCreator 2.4.0 and ran pdfcreator-2_4_1-setup.exe.
I got the message Please restart your system first to contine setup
I restarted the system and got the same message.
I tried using /Forceinstall, but the same problem recurred.
Trying to reinstall 2.4.0 caused the same symptom.
Apparently something (a lock?) was left over after the uninstall.
How do I get back to being able to print?


It seems, that something blocks deleting the registry key “PDFCreatorRestart” in “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce”.
To delete this key, run “regedit.exe” and navigate there and delete only the key “PDFCreatorRestart”.
It might be better to restart your computer after that and then run the setup again.
If this doesn’t solve the problem, please come back to us.

Best regards

That solved the installation problem.

The key requires Admin/System privilege to delete. Perhaps the key was left over from a failed install attempt.

I suggest that /Forceinstall should check for this key and delete it if present. Anyone using that option should know what they’re doing!