PDFCreator 3.4.0 puts a lock on the PDF files it generates


#1

Hello,

I have downloaded the latest release of the free version of PDFCreator, which is 3.4.0 and am testing it on my laptop running MS Windows 7 Professional.

It works well so far except that PDFCreator holds a lock on the PDF file it generates. When I have my program print multiple files in rapid succession, PDFCreator creates all of the PDF files but then holds a lock on one of them. I haven't seen a pattern yet but it appears to hold a lock on either the first or the last PDF file generated. It would make some sense if it were the last.

I am using the default profile and have it configured to not open the generated PDF files after saving. I also have the profile configured to automatically save the files without showing a Save dialog box. Having the profile use interactive mode yields the same result.

After the files are generated, neither PDFCreator nor PDFArchitect appear on the Windows taskbar or in the Applications tab of the Task Manager.

The lock appears to be indefinite. To remove the lock, I end the architect.exe process using Task Manager. Then I'm able to move or delete the generated file.

I have tried disabling history on the PDFCreator's Home screen in case that's the reason.

Any advice would be greatly appreciated.


#2

Hi,

if ending the architect.exe unlocks the file, it most likely isn't a PDFCreator issue, but maybe connected to the PDF Architect preview handler. Do you actively use PDF Architect? If not, uninstalling it will probably solve the issue.

Best regards

Robin


#3

Thank you. Uninstalling PDF Architect did the trick!

Because they were installed together, and I didn’t see an option to not install PDF Architect, I was under the impression that PDFCreator was dependent upon PDF Architect, it’s not as it’s working fine without it.