PDFCreator in a TS environment


 I´m trying to setup the PDFCreator (tried 0.9.9 and now 1.0) to work in a Terminal Service environment within a Windows 2003 R2 Server.

 After install PDFCreator, the only configuration I did was turn on "Use Auto-save" and in the "Use this directory for auto-save" I fill in with "\\\\TSCLIENT\\spool".

 On the RDP client I have a "device redirection" that maps a local disc folder as spool "remote TS map" on the server.
(ie. rdesktop -r disk:spool=MyLocalPrints ...)

 For the PDFCreator.exe I followed the PDFCreator as a Service on Server 2008 (http://outputredirection.blogspot.com/2009/10/pdfcreator-as-service-on-server-2008.html), so I don´t need to get a logged session just to run the console.

 If I let the client connect with full desktop and run their own PDFCreator.exe in the tray, wherever I try to print I get a squared windows with the following error:
 Error-Nr: 75 (Path/File access error)
 Modul: modPDF
 Procedure: AppendPDFDocInfo
 Line: 50100

 And the PDFCreator.exe enters in a loop generating the file again and again when I click Exit Procedure, If I click Exit Program it closes and stop. But as far as I can see, the file is generated correctly on the client machine folder.

 If I try to print without a full desktop, running a specific application, like Wordpad.exe, for example, and try to rely on the PDFCreator.exe running as a service, for the client it looks like the print goes through, because there is no error, but the file is not generated.

 Stopping the PDFCreator service and let it running on the server console, I can look at the log. So when the client prints, in the log I can see the following:

`14/4/2010 17:43:33: Autosavemodus: 1files`

`14/4/2010 17:43:33: Autosavemodus: Create File '\\\\TSCLIENT\\spool\\test-Document.pdf'`

`14/4/2010 17:43:33: Ghostscriptparameter:`

`-IC:\\Program Files\\PDFCreator\\GS8.71\\gs8.71\\Lib\\`







































`C:\\Program Files\\PDFCreator\\Temp\\PDFCreatorSpool\\~PS156.tmp`

`14/4/2010 17:43:34: Error: GPL Ghostscript 8.71: **** Could not open the file \\\\TSCLIENT\\spool\\test-Document.pdf .; **** Unable to open the initial device, quitting.; `

`14/4/2010 17:43:34: Time for converting [PDF without encryption]: 00:00:00:119`

`14/4/2010 17:43:34: Autosavemodus: Create File '\\\\TSCLIENT\\spool\\test-Document.pdf' failed`

  I just want to print a PDF to a mapped folder on a RDP client without "save as dialog" in a transparent way to the user, so he doesn´t even notice that it is happening.

 There is a way to archive what I´m trying to do here or it is just out of the capabilities of PDFCreator?


 Thank you for any help.

I am not running pdfcreator as a service, but one user in our ts (citrix) environment has been getting this 75 error.  Once the pending document showed up in the pdfcreator print monitor, the user was unable to delete the file (this was my clue).  I first temporarily granted the user access to the desktop and tried to manually delete the temp files associated to the jobs that couldn’t be deleted within the pdfcreator print monitor gui - received the error "access is denied". I was able to correct the problem by granting users modify permissions on "C:\\Temp\\PDFCreator\\PDFCreatorSpool" directory. 

It does seem odd to me that this problem didn't happen for all users without permissions on this folder - suspect the user changes something in the configuration to produce the problem.  Stranger still as 'creator owner' does have full control on subfolders and files. 

Maybe for you, make sure that whatever account you are running your service under has modify permissions on this folder.  Good luck! 



We are still having the same kind of problems (error 75/Line 50100) using PDFCreator V1.2.0, Windows Server 2008R2 (not SP1) and Citrix XenApp 6.0.

As the original installation was an update of previous versions, we uninstalled PDFCreator, deleted every remaining PDFCreator Registry entry and then tried a Standard Installation of V1.2.0.

We still get the same error, as obviously users are not allowed to write to C:\\Temp.

Opening ACLs on C:\\Temp does work but we consider this to be a temporary workaround at best as this breaches various security guidelines.

We would rather have PDFCreator use the users Temporary Directory (%temp%).

Various tests in HKLM, HKCU and HKU.Default pointing PrinterTemppath to PDFCreator\\,   \\PDFCreator\\  and %temp%\\PDFCreator\\ didn't work, though.