PDFCreator in Windows server 2003 Enterprise edition (SP2)

Hi everyone!

I'm trying using PDFCreator in "server" mode (v.1.4.1) on a Windows Server 2003 Enterprise edition x86 (SP2) platform.

Unfortunately i'm having a lot of troubles. 

Installation (in italian) works like a charme and application opens perfectly, but when i try to open "options" menu, the language turns automatically to english. But the worst thing is that the "Save" button doesn't saves settings at all! I can edit all settings stuff like  "Update interval", "Auto-save" settings etc..but when i close and reopen application, all my settings are lost!

I looked into the "HKEY_LOCAL_MACHINE/SOFTWARE/PDFCreator/Program" registry keys and all settings are stored correctly. It seems that PDFCreator can write data into registry but it can't read them.

I don't know what to do...

I didn't find any problems on other platform such as Windows 7 32-bit/64-bit, Windows XP, Windows Server 2008 R2...Only wth Windows Server 2003 Enterprise edition x86 (SP2) i found this issue. Even on an new and empty virtual machine, so it seems to be easy to replicate. 

Reading elder post i noticed that similar issues comes out in 2011 as i read in this post http://de.pdfforge.org/forum/help/6798-not-saving-profile


Someone can help me?

Thanks in advance!


P.S. I installed and ran PDFCreator with an Administrator account with all possible permissions, so i don't think this issue is related to administrative rights.





I think it is a bug in the group policies feature:

A workaround seems to save the options to a INI file an call pdfcreator.exe with the /OptionsFile parameter:

pdfcreator.exe /OptionsFile"C:\\MyPDFCreator.ini"

Tim Gerundt

Thanks!!!! With the \\optionsFile startup parameter works very well but if i try to run PDFCreator as a service like explained in this page  http://rainyrat.wordpress.com/2010/01/22/pdfcreator-as-a-windows-service/ it doesn't work on Windows Server 2003 Enterprise SP2.

In the step 4.3 i set as Application registry key the value "C:\\Program files\\PDFCreator\\PDFCreator.exe /OptionsFile="Settings.ini"" (Settings.ini is my PDFCreator's configuration file located at the same path of the executable).

Unfortuantely when i run the service and i print on the PDFCreator default virtual printer no pdf file seems to be created into the auto-save directory, while if i run the executable with the \\optionFiles parameter and then i launch the print, the pdf files suddently appears.

I'm completely messed up...

Someone has got some suggestions?


Thanks in advance!



Please use the full filename for settings.ini. You can use the reg key "AppDirectory" to set the working directory also. Check this articles.


Best regards,

 Tried to configure AppDirectory and AppParameters like reported here  http://wiki.sabnzbd.org/windows-service and worked very well.


Thanks for your support!

Hope that this problem 'll be fixed in the next release!