PDFCreator no printers installed

I am having the same issue as the "No printers installed" posted (not able to link)

I am getting the same errors as they did and the PDFCreator is not listed in my Printers. I have have tried about 20 possible solutions suggested by you in the forums. It seems like the driver is just missing like it was for this person? Can you please send the printer driver to install? That fixed the issue for them.

ok great, then we can get started troubleshooting the issue. First please run cmd.exe as administrator and navigate to the PDFCreator folder (by entering cd “C:\program files\PDFCreator”).
Now, run printerhelper.exe /uninstallprinter
Does this work, or does it already create error messages?

C:\Program Files (x86)\PDFCreator>printerhelper.exe /uninstallprinter
2020-05-14 11:37:49.2412 [Error] 5600-1 () NLog.LoggerImpl.Write: No PDFCreator printer was found! [ResultCode: 3]


Attached is a .txt file with all of the things I have tried to resolve the issue
.PDFCreator No Printer Issue.txt (47.1 KB)

I tried some of the things again with removing the System32 Spool files and reinstalling. The Legacy client got me further.

I don't have a PDFCreator printer, but there's a PDFCreator driver now in Print Management.

When I ran the rpinterhelper.exe /uninstall, these were the only lines that weren't grey (there weren't any error lines):

2020-05-14 20:35:16.4129 [Trace] 1460-1 () NLog.LoggerImpl.Write: UnInstallPrinter: Started
2020-05-14 20:35:16.4129 [Info] 1460-1 () NLog.LoggerImpl.Write: UnInstallPrinter: No PDFCreator printer was found!
2020-05-14 20:35:19.8531 [Trace] 1460-1 () NLog.LoggerImpl.Write: UnInstallPrinter: DeletePrinterDriver: PDFCreator [Environment: Windows NT x86] not installed.
2020-05-14 20:35:19.8883 [Info] 1460-1 () NLog.LoggerImpl.Write: The printer monitor is not installed! [ResultCode: 0]
2020-05-14 20:35:19.9409 [Trace] 1460-1 () NLog.LoggerImpl.Write: UnInstallPrinter: Finished
2020-05-14 20:35:19.9672 [Info] 1460-1 () NLog.LoggerImpl.Write: Printer uninstalled successfully [ResultCode: 0]

Then I ran printerhelper.exe /installprinter PDFCreator /portapplication "C:\program files\PDFCreator\PDFCreator.exe"
No yellow errors, but these lines were not grey:

2020-05-14 20:36:01.0850 [Info] 12220-1 () NLog.LoggerImpl.Write: Driver installed successfully
Last error message: The specified module could not be found

Attached is the SetLog that popped up with the installation error.Setup Log 2020-05-14 #003.txt (184.5 KB)

Any help would be appreciated! Thank you!


I have been suffering this problem for a few years in different new windows installations, without finding a specific reason.

Today I discovered that the problem comes when you have previously installed the VNC Connect program.

If you first install VNC and then install Pdfcreator, it will give the error that you show (at least in my case that happens and I have checked it on a virtual machine in several tests). I don't know if it can happen with other software.

The problem is that although I have uninstalled the VNC and cleaned all the windows installation and reinstalled the PdfCreator, the error still exists.

I hope I have helped with this to give an idea and find a solution to the problem.

Greetings and thank you



Llevo unos años sufriendo este problema en diferentes nuevas instalaciones de windows, sin encontrar un motivo concreto.

Hoy he descubierto que el problema viene cuando previamente has instalado el programa VNC Connect.

Si primero instalas VNC y despues instalas Pdfcreator, dara el error que muestras (al menos en mi caso eso ocurre y lo he comprobado en una maquina virtual en varias pruebas). Desconozco si puede pasar con otro software.

El problema es que aunque he desinstalado el VNC y limpiado toda la instalacion de windows y vuelto a reinstalar el PdfCreator, el error sigue existiendo.

Espero haber ayudado con esto para dar una idea y buscarle una solucion al problema.

Un saludo y gracias