Please help me! I have installed PDFCreatoor on my computer & it simply WILL NOT PRINT!
Sometimes the program won’t even open!
What is the problem?
I have tried uninstalling & reinstalling it, Have messed around with it for some time, had it working at one point , but as of now it simply will not print!
If I print something with this printer while watching what’s in the print queue for that printer, it will flash in the window & disappear as if it went to the printer, but I disappears right away & won’t print!

I’d like to use it to print multiple files to the same PDF file, so please if someone could help to know what the problem really is that’d be nice.

I have installed PDFCreator on several computers & this is the second computer that I’ve had problems with; I ended up purchasing software that I thought would give me phone support & they wouldn’t give me the assistance I was looking for on the PDFCreator!
I finally created an account so I could post on the forums to get help.
What could my problem be? It almost seems as if there’s something wrong with this program…

Thanks in advance for any help.


sorry for the trouble.
There are multiple possible reasons for this, so please allow me to ask you some questions in order to be able to find a solution more quickly
Did you install PDFCreator as update on top of an older PDFCreator version, or was it a fresh install on the system?
Are there files piling up on the machine in %temp%\PDFCreator\spool?
Which version does the pdfcmon.dll located in %windir%system32 have?
Does printing a PDFCreator and Windows testpage from the PDFCreator application settings work?
If only the PDFCreator testpage works, but the Windows testpage doesn’t, it means the issue is somewhere inside the spooling procedure,which in most cases it is incorrectly configured permissions for the %temp% folder.

Best regards


I have a very similar if not the same problem. Version 2.2.2 worked fine on my PC (ThinkPad T410 under Win7 Pro 64bit), but after updating to version 3.1.0, printing to the PDFCreator does not work any longer, i.e. each task is only put into the printing queue and then just sits there forever.

I have thus de-installed PDFCreator, rebooted the system and reinstalled PDFCreator, but to no avail. One further idea was then that the problem might indeed be related to the spooling folder (%temp%\PDFCreator\spool), because that was not accessible to me in first instance when I tried to look into it with Windows Explorer, but even after fixing the permissions to be the same as for the %temp% folder itself, the problem persisted.

I have tried to print a test page from the PDFcreator application. There, the PDFCreator testpage works, but the Windows testpage does not. That could, according to your post, be an indication for incorrectly configured permissions of/within the %temp% folder, but then I would have no idea what could be wrong with settings that work with all other problems and even the version 2.2.2 of PDFCreator. Could you perhaps mention how the settings should look like in order to make PDFCreator work in version 3.1.2?

The version number of the pdfcmon.dll in my %windir%/System32 folder is

Thanks in advance

Edit: I have now also tried to completely empty the %temp% folder (thus also erasing all subfolders), set permissions to ‘full access’ for the system, for local administrators and for my own user account (as looked up on another PC). Then started PDFCreator again for debugging and trying to print testpages - with the same result as before: PDFCreator testpage prints out fine, but Windows testpage does not. So, fiddling around with permissions did not resolve the problem for me.


sorry for the trouble and thank you very much for your detailed feedback.
PDFCreator 3.x requires the same permissions as 2.x (read and write access for the user and system account, which are on by default), so if it didn’t work even after granting access to everyone, I am not sure what could be causing the issue.
Does a PDFCreator\spool folder get created in the %temp% path when you print something to the PDFCreator printer.
The pdfcmon version you have is correct.
Do you have a registry key named HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\pdfcmon\Ports\pdfcmon ?

Best regards


Thanks for the quick response. Happy to say now that I was able to solve the problem on my own just before visiting this forum again.

The solution was to completely de-install and then reinstall PDFCreator after adjusting the permissions within the %temp% branch (which alone did not do the job - see above). Apparently, some internal program settings had been compromised during the first install with some peculiar permissions in my %temp% branch and could not be repaired by removing those peculiarities. But a ‘clean’ install then went through smoothly and produced a working printing environment - as intended.

Thanks for your support (and also for a great piece of software)

Robin I have been busy & out of the office some, but I finally got around to checking this out and here is what I find.
As far as the install type I first installed it (not sure what version) then I was having trouble & ended up Uninstalling & reinstalling it (probably 1 time), I believe that install would be the current version unless there would have been any updates installed since then, current version is, PDFCreator Free v3.1.2 Build 10844.

Yes there are files piling up in “%temp%\PDFCreator\spool”

In the folder: This PC\OS (C:)\WINDOWS\SYSTEM32 (May not be the exact file path) if I right click>properties>Details the file version shown is

If I go open PDFCreator>Settings>Debug then
Try: print PDFCreator test page; That will print a test page; as well as I printed 3 of them & merged them together, so that’s working.

When I try to print windows test page from the same place: it will simply pile 2 more files in C:\Users\Username\AppData\Local\Temp\PDFCreator\Spool

So how do I fix my problem?
Thanks in advance for the help!

EDIT: I discovered if I open the PDFCreator>Settings>Debug Show log file Open that & the basics of what is says is

The spool folder is not accessible due to a permission problem. PDFCreator will not work this way

PDFCreator was not able to repair your spool folder. Please contact your administrator or the support to assist you in changing the permissions of the path

PDFCreator was not able to repair your spool folder. Please contact your administrator or the support to assist you in changing the permissions of the path


please ensure your user + the SYSTEM account have read/write access to your %temp% folder and manually delete %temp%\PDFCreator. PDFCreator will then automatically create the folder again on the next run and the folder should inherit the correct permissions.

Best regards


And how do I check / change these permissions?
This is what I find:

If I click Edit, In box shown above, then Add in the next box that pops up: here you see what I have.

So what steps to I take to add the permission as you say I should do?



first you will need to take ownership of the folder, then
your user account and the SYSTEM account will need read/write access to the temp folder.
This really isn’t a PDFCrator issue and therefore not covered by our support, but here is link to a general guide:

Best regards


Ok, thanks Robin for your help!
I’ll check it out!

Thanks so much Robin!
As of just now it’s working!

1 Like