PDFCreator stops working when I logg off my server 2008 R2


I install PDFCreator on a Windows Server 2008 R2. PDFCreator works fine until I log off the system and will stop taking requests. I have to lock the server instead of log off for PDFCreator to continue taking requests. Is there a way to create another service that PDFCreator will use and will not terminate if I log off?
Any help would be appreciated.


Anyone else has encountered this issue before and has a work around or any idea how to fix this issue? I would like to log off the system instead of lock.




Hey Ben,

How does it work on 2008 R2 other than that?  Others have reported crashing on 64 bit and I am hesitant to go ahead with the install.

After a bit of tweaking I have managed to get it running on a 64bit Win2008 R2 Server.
I have a service Account created to run PDFCreator as a service, this worked ok on our old 2003 print server, but on the new one it kept just spooling the jobs till someone logged in.

After some poking around on these forums I finally worked out what was going on.

The trick is the change of how running as a service now works, you currently can not change the settings of the 'Run as a Service' version by using the options setting in the program, as the Run as a Service version runs in its own space.

To fix this, configure the settings you want, copy/export them out of the registry location
and then make sure that the registry entry
HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\PDFCreator\\Program matches those settings.

The local machine section seems to be where it draws the settings from when running as a service and the programs option settings does not update these settings.

Note: Make sure Update Check is set to Never if you have a firewall. As the pop-up error saying it can not contact the update server will stop PDFCreator from working as a Service. (As the dialog box is displayed in the invisible session the Service is running in, so is impossible for you to click ok)

Took me a bit to find that one, but setting "UpdateInterval" to 0 (means Never) finally fixed it for me.