PDFCreator under Wine

I appreciate PDFCreator has not been built to run on linux, but I am hoping someone else has had a similar problem and has a solution.  I have used it a lot, to good effect, under Windows to produce reports that are text-searchable.  

Having moved to Linux I still have one or two reports that have to come from Windows programs, which I run under Wine.  Unfortunately the native linux print-to-pdf facility (CUPS-PDF) produces PDFs that cannot be searched.  So I tried installing PDFCreator 1.5.0.

All goes well to a point.  The program installs and reports it is OK.  The PDFCreator program runs, and shows the PDF printer on port pdfcmon is the default.  Windows programs can see the printer, and give no obvious error when I print to it.

However, from then on nothing happens.  Looking deeper I find an error as follows:

  fixme:winspool:SetJobW Ignoring everything other than document title
  fixme:winspool:ScheduleJob can’t schedule to port L"pdfcmon"

It seems that the port pdfcmon is not well defined enough, and/or what it points to doesn’t exist.  I tried creating a port in Wine but am not sure what program should be invoked via it.

Has this been seen before and is there a solution?