Printing after generating PDF is very slow!

Hi! When I print 10 pages over my Kyocera printer, it takes 40 seconds. When I print the same documents over PDF creator, it takes around 1:45min (so more than twice as long as without PDF Creator). What happens is, the printer is printing one page, then waits, then print another page, then waits and so on…

Why does it take so long? The PDF Creator finish the job quickly, but it seems like the Kyocera printer has a problem to receive the data! I use Windows 7 (64bit) and the printer is connected through a Gbit-LAN.

PDF Creator Version is 2.0.1

Ideas anyone?


Hi there,

I'm responding as I may have encountered a similar or the same issue, but do not want to hijack your thread.

You may want to check the log file of PDFCreator.
For more detailed information, you can increase the log level before you reproduce the issue,

How to increase the loglevel:
Start PDFCreator
Click on Application settings
Tab: Debug
Set the value to Trace or Information.

Here you can also Display the log file after reproducing the issue.

It seems that a process is killed after 60 seconds (looking at your timing information).

I just posted an issue that may be similar: Error: [Error] pdfforge.PDFCreator.App.App_OnStartup: The file "....." could not be printed!

Kind regards,

I just spotted something that could help by finding a solution! I create a PDF file with a watermark background. This file has a size of 170kb and the output file has a size of 177kb. So these are small pdf files (vectorized).

When i watch the printer printer task of my Kyocera printer, the filesize of each page has a size of 190Mb!! How can it get that big?!? Maybe thats the reason why it takes so long?!

I would like to post the trace logfile but that’s impossible due to too many characters :((((((

Could at least somebody from the devs say that you have absolutely no idea?



Perhaps you can post the log cut into pieces that do fit (multiple "Post comment"s) or just the part where the warnings/errors appear?

That’s a problem, because there are no errors or warnings… The printer is just extremely slow!


sorry somehow we managed to overlook this post despite all the bumps, please send the log to and we will have a look at it.

best regards,


Is there any update on this issue? Any pointers will help. Thanks!


I am afraid we never received a log for this, if you are encountering the same issue, please turn the logging level to “trace” in the application settings->debug, clear the logfile, start a print job with automatic printing enabled and send us the resulting log. We haven’t been able to reproduce this here.

best regards,

i’m encounter the same problem with the latest 2.1.1 version, Please help. Thanks.

Try this:

. start printing a document
. on the “print” window, where you have to choose the printer you are going to use, click “properties” next to where you chose PDF Creator
. chose the “advanced” option
. chose 600dpi as print quality: for an unknown reason, mine was recently set to the highest value and I had the same problems as you: it took my computer 20 minutes (yes) to print, and the final .pdf file was 35000 mb (yes).