Problem after update to 2.0.2

After I had installed an update PDFCreator no longer works. I get the following error message:
pdfforge.PDFCreator.App.App_OnStartup: No file in InfoDataFile argument or file does not exist.
ow can i fix this.
I have reinstalled several times.
I adapted the rights from c:\Users\cad\AppData\Local\Temp\PdfCreator\Spool\
I hope someone can help!!


haven’t seen this error before, please try if uninstalling PDFCreator, rebooting your computer and installing again afterwards solves it.

best regards,

It started with
that PDFCreator could not read files in C: \ Users \ cad \ AppData \ Local \ PDFCreator

I had put the directory from read only to completely open. Still the same error. In the printer box no message.
Yesterday I had a few ps files in the C: \ Users \ cad \ AppData \ Local \ PDFCreator dir.
I did install the PDFCreator-1_7_3_setup.exe, this version has worked, but no more
and also the version PDFCreator-2_0_1-setup.exe the same.


please start the PDFCReator.exe, go to application settings->Debug and change the logging level to trace, then click on clear logfile and start a printjob (anything but the PDFCreator testpage) and send the resulting log to, it should contain additional clues about what is going wrong.

best regards

I have exactly the same issue, here is the log:

2015-03-12 08:59:50.8914 [Info] pdfforge.PDFCreator.App.App_OnStartup: Launched PDFCreator with InfoDataFile parameter.
2015-03-12 08:59:50.9304 [Error] pdfforge.PDFCreator.App.App_OnStartup: No file in InfoDataFile argument or file does not exist.
2015-03-12 08:59:50.9304 [Debug] pdfforge.PDFCreator.App.App_OnStartup: Ending PDFCreator

Out of Debug section I can print test page of PDF Creator, but the above’s issue happens too for Windows test print page.

I dont have Adobe Reader installed. Instead I use SumatraPDF viewer.

What is really funny I cant install Adobe Reader (on an almost fresh Windows - I reinstalled it recently)  - I get 2203 error no matter what. I hope Adobe Reader is not required by PDF Creator.

My version is

I went to PDF Creator directory, found RepairFolderPermissions.exe and run it., but it didnt help.

I found this:

   82                 if (!String.IsNullOrEmpty(infFile))
83 {
84 if (File.Exists(infFile))
85 {
86 newJob = infFile;
87 Logger.Debug(“Added + infFile + as new Job.”);
88 }
89 else
90 {
91 Logger.Error(“No file in InfoDataFile argument or file does not exist.”);
92 return;
93 }
94 }

It would be helpful to have
infFile in that message too (on the line 91).
Something like:

91 Logger.Error(“No file in + infFile + InfoDataFile argument or file does not exist.”);

Hmmm I think it has to do something with my new setup (users dir is on 
the D: drive, not C:) and access rights to TEMP dir. I applied following
 thing:<br><ol style="list-style-type: decimal"><li>Click <b>Start</b>, type <b>%temp%</b> in the <b>Start Search</b>box, and then press Enter to see the default temporary folder.</li><li>In the address bar (at the top of the window), click the folder to the left of Temp (it is named "Local" by default).</li><li>In the folder list, right-click the Temp folder, and then select <b>Properties</b>.</li><li>Click the <b>Security</b> tab, and then click <b>Edit</b>.</li><li>Click <b>Add</b>.</li><li>Type <b>Everyone</b>, and then click <b>Check Names</b>. "Everyone" should now be underlined.</li><li>Select <b>Full Control</b> under <b>Allow</b>, and then keep clicking<b>OK</b> to exit all windows.</li></ol>In my case I added rights to Guest and SYSTEM (I could not add Everyone).<br><br>It allowed me to install Adobe reader. After the closing the PDF Creator and process and some related "Hook" process it works perfectly.<br><br>I wonder why I need to set those rights on "my" temp folder to make it work, but I guess its my setup issue. Of course it would be nice if PDF Creator was a bit more informative in its debug messages :)<br><br>TBH I am not sure if those folder settings helped or the Adobe Reader install - for now I dont care.<br>


the temp folder problem is a known issue but not caused by PDFCreator. I got mislead by the first post thinking the permissions had already been checked. What happens is, if the actual temp folder has incorrect permissions, the PDFCreator folder created below it inherits these permissions. We haven’t found out yet, which third party application might be modifying the permissions for the temp folder. It is not neccessary to grant everyone permissions for the folder, only the user running the PDFCreator and the sytem account need to have full access.

best regards,