Problem with the options signing and Security

When I only establish the options in the Security Tab there is no problem creating de pdf file or when I only establish the options in the Signing Tab it works fine but when I combine the 2 options it causes an error.

It causes an error even setting the PDFOwnerPasswordString value equals to the PDFSigningPFXFilePassword in the Registry.

Is there no possibility of signing and protect a document?

Thanks in advance

I have similar behavior ... for PDF file formats I can either enable the "Use Security", or I can enable Signing, but I cannot have both options selected. I get a different error, however:

Error-Nr: -2146232800 (PdfReader not opened with owner password)

Modul: modGhostscript

Procedure: SignPDF

Line: 50310


I get this error immediately after typing in my certificate password. A couple of other notes: I generated my certificate using Acrobat Reader 9 Tools --> Security Settings ... -> Digital IDs --> New ...

Also, this is using PDFCreator 0.9.9, using Ghostscript 8.14 Encryptor or pdfenc (same error for both engines), High Encryption Level (128-bit).

Thanks in advance for any help with this issue.


Getting the same error here although it still gives an error when only the signing tab is enabled. Again, I believe the cert was generated by Adobe.




I created an openSSL CA to create test certificates and it still fails. Error message below:

Error-Nr: -2146232800(PdfReader not opened with owner password)

Modul: modGhostscript

Procedure: signPDF

Line: 50310

same problem

if I use only "security" option (without signing) everything is ok
=> document is password protected/encrypted

If I use only "signing" option (without security/encryption) everything is ok
=> document is digitally signed

If I use both options "security" and "signing" together:
=> error raised
          Error-Nr:    -2146232800 (PdfReader not opened with owner password)
          Modul:    modGhostscript
          Procedure:    SignPDF
          Line:         50310

Any ideas?

Regards HG

Is fixed in version 1.0.

Check the svn log please.

Sorry, but what files of the svn do i have to change/copy to the PDFCreator directory?

i copied the "readme.txt", "SignPDF.vbs" and "pdfforge.dll" to the PDFCreator\\Plugins\\pdfforge directory. But when i tried it the security settings now are usable for me - but the signing doesn't work anymore. I always get an error.

PDFCreator 0.9.9 - Error message
          Error-Nr: 5 (Ungültiger Prozeduraufruf oder ungültiges Argument)
          Modul: modGhostscript
          Procedure: SignPDF
          Line:      50310
          Date/Time: 04-12-2010 / 01:37:29
 Windows 7 6.1 Build 7600 ()
  [TerminalServer IsWinXPPlus IsWinVistaPlus IsWindows7 IsWindows7Ultimate]

In the SignPDF.vbs there is a line:

pdfforgePDF.signPDFFile fname, "", tfname...

but in the readme.txt it's

void SignPDFFile(string sourceFilename, string ownerPasswordSourceFilename, string destinationFilename,...

"ownerPasswordSourceFilename" = "" ???

Could this maybe the error ?

Please give us a ZIP-file for download with the corrected files so we can use security and signing together. And please tell us how we can use both features together with automatic saving of pdf files.

Thank you.

I like your illustration work, your creativity and designs are really amazing.  company logo design . There are certainly a lot of details like that to take into consideration.