Problems since recent jumbo W7 update

I run PDF Creator on two Windows 7 PCs and ever since the recent end of July jumbo Windows 7 update I have had problems on both machines. I upgraded to the latest version of PDFC but the problems persist. A classic instance is that I print one page of an online document successfully using PDFC and go to add to it another page and find the PDFC (and PDF Architect and Msft XPS but not my HP Laser printer) has simply disappeared from the print options. Sometimes I can recover the position by restarting PDFC (in which event the others return as well). But sometimes I get a message saying my spool driver needs restarting. In that event the only way out is to uninstall PDFC and PDF Architect - on one occasion having to delete all references to them in the Windows Registry and then reinstall.


we haven’t directly heard about this yet, does it always occur if you try to add a second page like described above, or only some of the time?
I will try to reproduce this on a Win 7 VM.

One thing which might help until there is a solution:
You can restart the spooler by running cmd.exe with admin rights and then using the commands

net stop spooler
net start spooler

Best regards,


Thanks very much Robin. Sometimes it doesn’t appear as a choice at all but sometimes it disappears after the first page.

I had restarted the Print Spooler in Services (if that’s the same thing?) but that didn’t seem to help



Friday 5 Aug 16 9:50 BST: Robin, I thought it useful to update youThis morning (every morning i use PDFC) I had the full gamut: 1st page ok. PDFC not offered with second page. Restarted PDFC and received print spooler restart message. Checked Print spooler and it was started. Tried to print second page and was offered PDFC in Manage list. Selected it and pressed print but page hung at “Loading preview”. This last variation not mentioned to you before.

Sunday 7 August 09:54 BST. Same problem as on Saturday. This time by leaving the Services window open i found that the Print Spooler – which i had restarted as instructed – seemed to stop working when I re-selected PDFC from the manage list

Sunday 7 August 13:40 BST. Further investigation shows that the Print Spooler once restarted stops as soon as you select Connect in the Windows PDFC printer screen