Prompt for PDF Architect Problem

I looked up this issue in the forum. Found a discussion and wanted to comment. When I left to create an account, I could not find the original post. However, there was much discussion as to why one could not get the “Open File …” to get past requesting PDF Architect. Since this seems to be a rather large undertaking to determine what in the .NET framework is causing the problem, why not add a field to the Profile Edit that allows us, the user, to simply enter the name of the PDF Reader of our choice. Seems as though this would get by all of the road blocks. Even it the filename required full Path name, it would seam that a “browse” function could be implemented to make the job a bit more foolproof. I have two windows 10 laptops. On one, it does go to the default .PDF application. The other always asks about PDF Architect. The one that is not working is the most recent version as I downloaded it just before writing. The other computer that does get the default app for .PDF Files has version 2.5.


Hi @DannyDont,

Thanks for your feedback!

From what I know the issue is that the default software/app isn't saved correctly in some cases.

Changing the default viewer in Windows to Firefox or another Webbrowser and then back to your favorite viewer sometimes does the job.

A fail proof option is the "Script" Action from Profiles -> Advanced
(Make sure to deactivate 'Open file after saving' in Profiles ->Save)

Of course, I will forward your feedback to the dev team.

Thank you for responding. I will look into the Script idea. My suggestion might not be “glamorous” but it should be something rather simple to implement. Of course I don’t know your code behind the scenes but in my day as a Software Engineer, it would not be too difficult. I do appreciate you passing it on, whether it gets implemented as a stop gap or not.

Thanks and and Merry Christmas and Happy New Year!

Hi Danny,

actually what you suggest was originally the plan to solve the issue, but after adding improvements to the detection of the default application and doing a lot of manual testing we thought to have resolved the issue for good. But there can still be cases e.g. if the default viewer doesn’t register correctly with Windows, in which the option to select your reader from inside PDFCreator would help. Are both machines using the same default viewer?

We will closely keep an eye on the situation and if there still seem to be a lot of issues with the automatic detection, the solution you suggested will most likely get implemented in one way or another.

Best regards,


Hi there,

In PDF Creator v3.1.1 (Build 10348) on Windows 10 Pro v1709.16299.125 / 64-bit, the “Open in Default Viewer…” action triggers the PDF Architect / “No application is associated to open PDF Files” prompt when the user is logged in as a non-administrator account.

If the user is in an administrator-level account, the “Open in Default Viewer…” action works as expected.

(The machine has a default PDF viewer installed and set in Windows settings on both accounts. I have tried changing the Windows file association setting for PDF to different apps, but this does not affect the above behaviour).


I am not sure I totally understand. But I checked and I do (now if not before) have a default app set for PDF files.
So now, I am running as Administrator, (which I believe I am all the time), I should get the default viewer?
If for some reason I am NOT logged in as Administrator, I am not sure if I will get PDFArchitect or my default PDF Viewer.

What would the action be if I were logged on as Administrator and I had no default PDF viewer? I am thinking that I would get PDFArchitect. This may be what was happening but I did just check now and I do have a default set. Perhaps I installed a new PDF reader and it set the default for me as I do not remember doing so.

I will run some test and leave with thanking you for your help … Thank You!


if your default viewer is Adobe Reader DC, it might help to use the “make default” button from the Adobe Reader settings to fix the issue (clicking the button is enough, the additional steps afterwards aren’t required). This will change the registry setting in the expected place, while setting it through the Windows Control Panel will most likely not have any effect (depending on your exact Windows version).

Best regards


Hi there,

I came across this topic because I have the very same issue in version 3.2.1. Did you find any solutions in the meantime?
What I tried so far (on WIndows 10 with PDF-Xchange Viewer set as the standard PDF viewer):

  • update to version 3.2.1 of PDF Creator
  • disable the automatic display of newly created PDF documents
  • in the Windows control panel, change my standard viewer to Opera and then back to PDF Xchange
  • Open PDF Xchange, go to the settings and click "Set as standard for PDF"
  • log in as admin and repeat the last two steps.

None of this seems to help. As a standard user, I still get the PDF Architect prompt, and as admin, I get the resulting PDF displayed in PDF-XChange (I disabled the automatic display only in the user profile, not in the admin profile).

Best regards,

Hi Stefan,

if the automatic display of newly created documents is disabled, you shouldn't get the prompt regardless of any system settings. Are you sure this is setup correctly for the user profile? The user profile might have a different PDFCreator profile associated with the default PDFCreator printer than the admin. Do you additionally have a print action activated?

Best regards