Selecting Grayscale in Settings breaks compression - always outputs a LARGER file!


Whereas previously I could successfully reduce filesize through combinations of Grayscale, compression, and/or downsampling - now after an upgrade to the latest version today, regardless of what I select to save - if I have Grayscale selected - certain files always come out at the same huge size, around 32 MB, which is 16 x the original size in one case!

I am doing this properly, the way I did before - open Settings, change compression options, Save the options, then click Save to generate the file - and yet nothing I choose seems to work, any time compression is enabled I just get a comically/tragically large file that actually makes the problem WORSE.

I can’t imagine why the Grayscale option would be a problem as (A) the files already seem to be grayscale and (B) surely making things B&W could only SAVE space, since then you don’t have to encode the separate R/G/B values.

I tried this with a file that already had obvious colour, and it compressed OK. What is it about my other files that breaks the Grayscale option and causes them to inflate massively when ‘compressed’?

As this worked perfectly before I updated, I can’t imagine I’m doing anything wrong, but I’m happy to be told otherwise…