Version 2.00 and VB6


when trying to add reference from VB6 to pdfcreator.exe we get error that this file is not supported for reference.
even when trying to use late binding the command CreateObject(“PDFCreator.clsPDFCreator”) returns an error "ActiveX cant create object"

it think it might relate to the fact that the new version installs on Program files instead of Program Files (x86), although I think it’s a 32bit app.

any help on this ?

I second this issue. Same thing is happening in VBA with Excel. I’ve been using late binding for years without issue, and now it got horked.

I also tried early binding, but cannot get that to work, either. PDF Creator is no longer available in references.

The issue has become critical because uninstalling 2.0 and reinstalling 1.7.3 does not fix the issue. Whatever happened seems to be permanent, or at least the installers are forcing the same error for install every time. I even wiped out the registry for pdfforge, pdfcreator, and pdfarchitect, installed the very old 0.9.6 version, and could not get that to work, either.

Was this intentional? If so, how do we need to change the code?

Do we need to register the clsPDFCreator library? If so, what lib is it in?

BTW, code to register should be: regsvr32 /i “C:\Program Files\PDFCreator\xxx.dll” I just need the xxx filled in.


you can´t use class clsPDFCreator anymore. You can create demanded object e.g by CLSID. Just search through Windows registry by e.g "PdfCreator.exe"

new PDFCreator class has CLSID "69189C58-70C4-4DF2-B94D-5D786E9AD513"

By now, most things are handled by Queue object - CLSID "66A9CAB1-404A-4918-8DE2-29C26B9B271E"

Hope PDFCreator developers will produce better manual…

Haala, thanks.

If you or anyone gets this to work in VB (or C#) please post up a snippet. I’m not sure how to proceed given your input, though it is nice to know that Forge killed this feature. I hope this is easily resolved, otherwise I will need abandon PDFCreator.

Also, does anyone know why uninstalling 2.0 and reinstalling 1.7.3 will no longer work? I kept a bunch of install .exe files from over the years (been collecting almost since the beginning) and none of them function anymore. Does 2.0 sabotage, or do the installers recognize something online and kick back a sabotage? If so, I would love to disable just that one reg key, reinstall 1.7.3, and tell everyone do NOT upgrade PDFCreator, ever.

Thanks Daniel for bringing this up, and thanks a bunch to the responders.


usually there shouldn’t be any problem with reinstalling PDFCreator 1.7.3 after having uninstalled version 2.0. Maybe a reboot is required in between. Are you getting any error messages?
We had to redesign the COM interface to make it more stable, so all future versions will be backwards compatibble to the 2.0 version. You can find detailed descriptions of how it works in the manual and sample scripts in the COM Scripts folder inside the main PDFCreator path.

best regards,


If you’re with PDFF, then check the back install locally on your machines. I’ve tried it on multiple machines without success, and that includes a complete registry wipe (manually, which is always unclean).

I suspect either the uninstaller does not clean up enough (there were a ton of reg keys still present), and/or the installer for older versions kicks off some sort of auto-update. Probably the uninstall cleanup is the problem. This may not be a care-about from your point-of-view (you want to prevent back-installs, and what better way than with an uninstall bug), but consider this: your 2.1 release is corrupted by your 2.0 uninstall. I could be wrong, but it’s a good idea to investigate this behavior.

In any case, for those following this post, the fix I’ve found so far is this:

1) Roll the computer to backup prior to updating PDFC.

2) Advise users to avoid PDFC updates.

3) Keep an older PDFC install .exe around for future installs.

4) Remind new users to avoid updating during install.

5) Study new PDFC documentation, audit other providers, pick a provider and rewrite the code from scratch.

Since this is not backward compatible with <2.0 versions, even a one-line fix is back to ground zero for developers. Deployment will be the same whether we use PDFC, Cute, Adobe or whatnot – rewrite the code and deploy a whole new PDF printing engine, along with whatever installs are required.

So we might as well take this time to reinvent and modernize our code, and see if PDFC and PDFF are still on top against their competitors, especially as PDFForge moves PDFCreator into the pay-for-use area. This is a whole different league than the open-source freeware that PDFC used to be.

Also, again I ask: If someone gets the new code to work, please post a snippet. I will do likewise.

Much thanks.
Cay, reboots were necessary, as you mentioned. There also could be an uninstall issue by removing Architect first. Not sure.

But fix I've found is this:

1) Uninstall PDFCreator and PDFArchitect, in that order, using the Control Panel -- Programs options. Be sure to uninstall both programs.

1a) Uninstall the PDFCreator print engine, if still present, in Contro Panel -- Printers.
2) Reboot.
3) Install PDFCreator 1.7.3
    NOTE: Do NOT install 2.0 when requested.
4) Reboot.

5) Recode your stuff and redeploy whatever permanent fix is warranted.

Much thanks.


is it not possible to reinstall the 1.7.3 PDFCreator or does reinstalling PDFCreator 1.7.3 not solve the reference problem?
Reinstalling and using PDFCreator 1.7.3 worked without any issues here (after having removed the 2.0 version).
PDF Architect and PDFCreator are not linked in any way which could break PDFCreators setup/uninstall functionality.
It was definetly not done on purpose and will try to fix it if it is a reproducable problem. We wouldn’t still be hosting version 1.7.3 on our website if we wanted to prevent users from using it.

best regards,

Hi Robin,

Yes I have, in the PDFCreator class you are referring to:



only. no other methods or properties…

in then examples there’s a check using IsInstanceRunning but no handling if False…
1. how do you start the instance if it’s not running ? (formally: cStart)
2. how do you refer to cOptions object ?

are there other methods to PDFCreator object ?


you don’t have to start PDFCreator at all, instead the method IsInstanceRunning is only provided for checking that no PDFCreator instance is running and if there is no instance running then you are able to get a reference to the PDFCreator job queue otherwise you would not be able to get this reference. From there on, all work is done with this reference on the job queue of PDFCreator. 

Please have a look at our PDFCreator Manual/COM Interface/User Manual/Basics/Convert a single file. In that we describe also how to set specific settings for a print job and how to change specific settings of a print job.