Version 3.2 windows7 64bit hangs on installation

windows7 64 bit ver 6.1 (build7601 sp1), patched up to date - SSD system disk, HDD storage disk

PDFcreator 3.2 installer

a) peskily tried to sneak in PDFarchitect and hung

b) after I finally uninstalled the whole and tried to install PDFcreator 3.2 without PDFarchitect, it also hung.

I killed the installer processes but PDFcreator appears to be installed and working (successful “print” of both pdf files and word files to PDF files)

c) in the install directory there are files with older modification date: days to of years before today’s though creation date is today.


sorry for the trouble.
In some rare cases, the third party offer screen which gets displayed at the end of the PDFCreator freeware installation doesn’t load / exit properly, causing the setup itself to hang. Fortunately, this is at the very end of the setup and shouldn’t have any impact on the PDFCreator functionality as such. Our offer partner is working on a fix.
Regarding the modification date, some files we use haven’t been modified for years, this is perfectly normal. The creation date is the date on which the files where copied to your hard drive.

Best regards