Will not uninstall or upgrade Windows 7 64bit

Original install is PDF Creator only, no Architect V2.1.2 Working fine no issues for months. Windows update seems to break it. Previous install had same problem PDFC starts with the 0% and stays there, no errors nothing. Re-formated for other reason reinstalled PDFC and it was fixed.

Current issue: V 2.1.2

  1. As above, will not print stuck on 0%
  2. Downloaded upgrade V 2.3 and on uninstall it stays on Pdf Creator uninstall status. Only way to stop is through Task Manager. Booted several times same result. (Task Manager does Not show it as not responding)
  3. Tried through control panel, same result.
  4. Deleted Printer, same result.
  5. I am unable to uninstall, re-install or upgrade.

How do I uninstall/remove it so I can reinstall it.


are you still able to run the PDFCreator.exe?
If yes, please go to the application settings->debug section and check if there are any errors in the logfile (if there are, please post them here). Do you get any error messages if you run the unins000.exe from the PDFCreator main folder directly, or does it also simply not seem to respond?

Best regards,


After deleting the printer as previously mentioned and now on running PDCreator from the start menu I get the thank you for downloading pdf creator dialogue including the ‘Would you like to download 2.3 version’ and the ‘Settings Dialogue’ but it doesn’t seem to add the printer again. Printers > Add Printer > pdfforge GmBH doesn’t seem to respond.

Clicking on ‘Show log file’ closes the program outright as does “Print a test page”

Remove all components > yes
Delete All application settings > yes
PDFCreator Uninstal Window is all greyed out. No errors, nothing. Task Manager to kill the application.

No log files or error messages.

I’ve managed to somewhat resolve the issue. I’ll post for others whom may have similar:

Note1: My install is without PDF Architect.

Note2: Make sure you know how to recover from a broken system and read all first. You can cripple your pc if you make a mistake or something goes wrong.

1.Create a system restore point
2.Backup the entire registry using regedit
3.In regedit do a search for pdfcreator and delete every parent key (folder). F3 will search for the next one. I didn’t count but there were around 20 parent keys (folders). IMPORTANT…Do not delete every folder you come accross. Only the ones specific to PDFCreator. You will find some entries amongst other entries. You can delete the entries but not those folders. Deleteing the wrong entries or keys can/will cripple your PC. Be careful, it’s your responsibilty! as a precaution backup each individual key before deleting.
4.Go to PDFCreator home folder, mine is in Program files and create a folder PDFbaktodelete
5.Move all files into the folder PDFbacktodelete
6.Install the same version you had. Mine was 2.x.x
7.Uninstall it. Uninstall should now work. It’s install failed to create a printer but uninstall worked.
8.Install the upgraded version, Mine 2.3.
10. Test to see if it works.

After a few tests it seems to work fine now, Though clicking on the log file still closes PDFCreator. Bug?
Once you’re happy it all works move the registry backup file int the PDFBaktodelete folder just incase then delete it after you are sure it all works. Though PDF creator being broken to begin with you should be OK to just delete it anyway.