Windows 10 PDF Architect starting new desktop can't open app

PDF Architect is starting up and the icon shows in taskbar.
Unable to open PDF Architect as it is in a new desktop on Windows 10 and will not display.

Program is running, and can see the app when I CTL-Tab.

Please help.


I am afraid I have not heard of this issue and am unable to recreate it here, so there is a high chance it is caused by a specific setting on your system. Do you have multiple screens? You could also try to reinstall PDF Architect, which often solves unknown problems.

Best regards,


Hi, I am experiencing the same issue. I attempt to open a .pdf and PDF Architect goes through all of its loading features and what not, makes a new icon at the bottom of the taskbar, but I can’t actually “see” the program itself. I’ve tried selecting it and moving it onto my screen, all to no avail. I just did an uninstall and reinstall and no change. I do normally use a second monitor, but have disconnected everything and am running just off the built in screen on my laptop. I disconnected from my Plugable monitor box, did a reboot, uninstall and started again all without the second monitor to zero change


I use dual monitors at work, but not at home.

I uninstalled PDF Architect and then connected the dual screens while at work.

I then installed and then pulled the PDF Architect screen to the laptop primary screen once it started.
Then closed PDF Architect.
Then started PDF Architect again to verify it would open on my Laptop primary screen.

All is well. What is weird is the application did not understand I had only one screen.
It worked fine in Windows 7 - but not in Windows 10.

I have the same problem. Using dual monitors 64bit windows 10 pdf architect opens and stays in the taskbar. using the desktop selector i can see it is running, but cannot access it. The program is always hidden, just a icon on the taskbar.
Using one monitor does not help


which version of PDF Architect do you have installed?
I am afraid so far we haven’t been able to reproduce or find a cause for this issue.

Best Regards,


Steps to resolve:

  1. Connect dual monitors
  2. start up PDF Architect
  3. It will open on the second monitor
  4. drag PDF Architect to the primary screen (laptop probably)
  5. close PDF Architect
    to test that it is corrected
    Start up PDF Architect again - it should open in the primary monitor.

The issue is that in Windows 7 the underlying software drivers knew if you had one or two monitors. With Windows 10 it seems the drivers do not know there is only one monitor.

If you can verify that PDF Architect opens in the primary monitor, it will work properly
when you have either dual monitors or a single monitor.
Just don’t drag the PDF Architect to the second monitor and then shut it down.
The software remembers which monitor it was open on and saves this.

Good luck

Please see my responses to this issue.

it is very easy to reproduce.


thanks for this, I will give it another try for sure.

Edit: Tried and wasn’t able to reproduce.
It will always open on my main screen no matter what I do.
Did you have both monitors connected while booting Windows or did you connect the second one afterwards?

Best regards,


I connect the dual monitors before booting Windows.

My staff and I have started experiencing this problem since we moved to a virtual server (Citrix). In the office we all work on 34" ultra-wide monitors (Dell’s u3415w) and utilize virtual desktops and a server with PDF Architect’s Terminal program.

Away from the office we are all working from our laptops or other computers with access to the virtual server. All the programs startup fine except PDF Architect, which starts up, but the window is out of sight like it’s sitting in the ultra-wide space used at work, which isn’t visible on the smaller screens/laptops out of the office.

I can understand the previous solution posted, i.e. close the program in the primary monitor, but this doesn’t exactly work in a one ultra-wide monitor setup like we have.

Any solutions to try would be appreciated. Thanks.

I found a solution to my problem and it immediately worked:

Right-click on the window caption on the taskbar, or select it and use Alt+Space.
If the Restore option is available, select it to pop the window out of minimized or maximized state.
Choose the Move option.
Hit an arrow key.
Move the mouse.
The window should then pop on-screen and attach to the mouse, where it can then be dropped at a usable location via left-click.



Thanks for sharing this, I really couldn’t reproduce this problem here no matter how i configured or setup dual screens.

Thanks, so far only way to get past this problem was multiple reboots, switching between displays and just praying - but you’ve saved my day! I have dual display setup with dock on one site, dual display with port replicator on another and of course plain laptop display when travelling. Every once in a while I got this problem, now always but way too often.

I’m working on a laptop (Win 10 pro 64bit) and at the office in a dock with a second display plugged in. When I open a PDF and view it on the external screen and close it the next PDF I open will be opened at the external screen. If the last PDF was on the external screen when I shut down the laptop and I start my laptop without an external screen PDF Architect will still open a PDF on the non existent external screen and I’m not able to get it to the primary screen. The Icon will be shown on the taskbar and I can see the preview when I hover over.
A solution is that when I have attached an external screen I have to be sure the last PDF I’m closing is on the primary screen before shutting down my laptop. Quite annoying.
Maybe this helps reproducing the problem?

1 Like

thank you, I have solved my issue following your instructions