Windows 7

have upgraded to Windows 7, but PDFCreator no longer works after upgrade


is a Windows 7 version available?

Uninstall PDFCreator with all settings, reboot and install it again. It should works. Tested here successfully.


Dear Frank


I am very sory, but you are wrong!

PDF creator ISNT working under windows7! - And the problem is not the INSTALLATION, but the actual pdf printing process - since the program isnt doing anything at all! - it isnt even working with the newer version of ghost script, so it is definitively a problem of the program.

Btw: I WAS a user of pdf creator, but since its absolutely useless, I changed to "FreePDF" - and this one is working absolutely properly on any OS (of Microsoft) I have used the last few years.
And it's free too.





please let me ask two questions: Have you updated from Vista to windows 7? And if so, have you tried reinstalling PDFCreator?

As written in the FAQ, Windows 7 rebuilds the permissions in a way that breaks PDFCreator (and also FreePDF and all others I know that work this way). Reinstalling does work here. I had the same after upgrading and I am successfully running PDFCreator on W7 now.

So it cannot be that PDFCreator is not working in general on Windows 7.

kind regards,


I have the same problem after upgrading from vista to 7.

(and also after re-installing PDFCreator)

When selecting print to PDFCreator (from Quarkexpress) nothing happens.

On occasions, after some changes in settings the creator suddenly turns up with all the previous vain attempts, and does them all properly.

So the print commands have been stuck somewhere in the spooler.

Any Ideas?





the printer driver stores the Data in the PDFCreator Temp folder and then calls PDFCreator. So no print jobs are lost, but you will have to call PDFCreator manually.

Which version did you install? (Just to make sure it is the latest)

Did you reboot between uninstalling and reinstalling?

kind regards,

Thanks Pillip,

It works now.

had re-installed without reboot between uninstalling and reinstalling.



great to hear! It sometimes happens, that the printer system is not cleanly shut. this isn't a problem normally, but if we are replacing a driver, this can cause trouble, so a reboot is the safest way.

kind regards,

I' ve been running into the same problem.

I've both a fresh installation of Windows 7 Ultimate and of PDFCreator.

When I try to print something, nothing happens. The same holds, if I try to start PDFCreator.exe directly from filesystem.(both with user's or administrator's rights).




Edit: I made another try:

Uninstall/reboot/install/reboot works fine, until ...

I'd try to print a Webpage from IE

In that case I get an error message:

Error Nummer 481

Module modMain

Procedure: StartProgram

Line 51720

After that PDF Creator cannot be startet.


I am having the same problem as Michael.  I have a fresh installed W7 Enterprise and fresh install of PDFCreator.  It got the 481 error when I try to print web page that contain graphics.  I tried remove the PDFCreator, reboot and reinstall and the problem is same.  I attach the error log that generated by the PDfCreator in this email for reference.




PDFCreator -




PDFCreator 0.9.8 - Error message



Error-Nr: 481 (Invalid picture)

Modul: modMain

Procedure: StartProgram

Line: 51720

Date/Time: 11-19-2009 / 11:48:02





VerMajor: 6 -> Unknown 'VerMinor':1 6.1 Build 7600 ()

[TerminalServer IsWinXPPlus IsWinVista IsWinVistaPlus




I'm in somewhat the same boat: running under a clean install of Win7 64-bit:

After a "save" to C:\\, there is no file visible.  Printing again, in the save dialog the previous saved PDF is visible, but not from Win Explorer.  Is the file being created with unusal permissions (my userid is the only one on the machine and is an Administrator)?

Work-around: if I save to a non-system disk (anything other than "C:"), or a location on C:\\ like "My Documents", the PDF is created just fine.  Maybe this is a "permissions" issue, and PDFCreator is just not properly reporting the create/write error?

Update: it appearsthat under Win7, the C:\\ root folder is protected under the default security setup.  Other programs besides PDFCreator fail when trying to save to C:\\, so its not a problem with this program.  I do wish PDFCreator would issue some type of error message when this occurs...

Hi, I'm new. I used the software, but I had the same problem when upgrading to windows 7. I uninstalled it and re-installed it and rebooted in between but nothing happens when I try to print from the web. I've tried what other people suggested. Maybe I'm doing something wrong?

Thank you for posting those tips about windows 7.

First off... Why are you installing in the root directory? To install (or write) in the root directory requires elevated priviledges. No sane reasonable person would even consider it especially since the directory root contains limited file/directory entries (for example you could have thousands of files/directories under (for example: C:\\Downloaded ) but the root directory (ie: C:\\) can only have a limited number (I don't remember the exact number but I believe it is under 2048 or 1024 for NTFS - for FAT32 it is 512). Even other file systems have similar limitations.

1.) Dont upgrade from Vista to Windows 7. Even if Microsoft advertises this method all the time it will cause many troubles. I havent seen any case where this worked without problems. Especially from Windows XP to Vista is a catastrophy.

2.) PDFCreator works on Windows 7. 0.9.8 works on Windows 7 and I have done intensive testing with Windows 7 x64 Ultimate.

3.) Saving documents to a system directory like "C:\\", "C:\\Program Files" or "C:\\Windows" cant be done with enabled UAC in Windows Vista/Windows 7 without an UAC prompt. The reason for this is that these are protected locations that should only be accessed by the system or an installer with an UAC prompt. This is not a bug of PDFCreator. This is part of the new security concept of Microsoft that Administrator rights are only used to install software, but not for daily work.

If you want the security setting of Windows XP you can disable UAC, but then every software can fill the registry or Windows directory with tons of useless data making your PC slower and causing problems.

4.) FAT16 only supported 512 entries in the root directory, but on FAT32 or NTFS there is no such limit, but you should also make subdirectories on your system drive. The system partition should be used for small files and should be stored in your user profile. Larger files should be stored on a data partition. I prefer the 2-1 rule. I have got 2 system partitions (for WinXP minimum 30GB, for Vista/7 minimum 50GB) and the rest of the disk is the data partition.

I also had been having problems with PDFCreator (0.9.8) and Windows 7 64-bit.  I just now found a solution to my problem; I don't know whether this is the same problem everyone else has, but I hope this helps...  First, how I found the problem; second (you can jump there if you're impatient) the solution.

Situation: fresh install of Windows 7, fresh install of PDFCreator.  Worked for the first few days; after that, I would print to PDFCreator and nothing would happen - no prompt for title/filename, nothing.  The print queue showed the job ("Error printing") but no useful information.  I could start PDFCreator manually, but my jobs didn't start up.  I uninstalled PDFCreator, rebooted, re-installed, and it worked again - for about a day; then the same thing.

I thought at first that Ghostscript was missing or damaged, but I printed a test page from inside of PDFCreator (rather than from the Printer Properties page) and it worked just fine.  So I looked a little deeper - I went to the Ports page; the port is "PDFCreator:"; so far so good.  I clicked "Configure Port", and found that the line "Redirect this port to the following program:" was set to (as near as I can remember; I didn't write it down) "C:\\PROGRA~1\\PDFCRE~1\\PDFSPOOL.EXE" - in other words, the mangled short-filename version.  Which would be OK, except that I'm using 64-bit Windows and PDFCreator is 32-bit, so it's located in "\\Program Files (x86)" - and the mangled version looked like it probably pointed to just plain "Program Files".  I clicked Browse, and sure enough it started in the Windows folder, which is what usually happens when the expected path doesn't exist.  I browsed to the correct path and clicked Open... and got the "An error occurred during port configuration.  Operation could not be completed" message.  Aha, says I, that's UAC.  So how can I modify printer properties as an administrator?  Maybe there's a clever way, but I don't know it; what I found was the following:


  • Open a command prompt as an administrator.
  • Temporarily activate the hidden Administrator account by typing net user administrator /active:yes
  • Leave the command prompt open - we'll be right back.
  • Switch User and log in as Administrator (account has no password by default)
  • Start/Devices and Printers
  • Right-click on PDFCreator, select Printer Properties
  • Go to the Ports page, roll down to "PDFCreator:", click Configure Port
  • Click Browse, navigate to the PDFCreator folder, select PDFSpool.exe and click Open.  (If it was already selected when you got to this point, then this was not the cause of your problem and I apologize for wasting your time.)
  • Click OK
  • If you had any jobs sitting in the queue, PDFCreator should start processing them immediately.
  • Close everything and log off as Administrator.
  • Back in your normal-user session, disable the Administrator account again (it's disabled for your security, not just for inconvenience): net user administrator /active:yes
  • And you're done.

1.) So this is not a Windows 7 problem, but more a 64 Bit problem that can occur in Windows Vista too (and theoretically in XP-64 too).

2.) Why not simply deactivating UAC? This should be the easier way than activating a new user account that will create a new user profile.

3.) The properties of other printers can be modified. It seems that this does not work because it is non Microsoft Code.

Just curious if anyone has found a solution for the Error 481 Michael mentioned above? I am running into the same issue.

>>1.) So this is not a Windows 7 problem, but more a 64 Bit problem that can occur in Windows Vista too (and theoretically in XP-64 too).

Possibly.  I never used XP 64-bit; I did have Vista 64-bit, but found UAC so crippling that I turned it off.  In general I think that UAC, and the principle of least-privilege, is a very Good Thing; it's just that in Vista it sucked very badly.  It's much more granular, and generally better thought-out, under 7; still, though, there are situations like this, where you need to run a Control Panel item as administrator but there's no way to right-click anything and select "Run as administrator"; hence the workaround I posted.

In any case, as far as I can tell, the problem is that the installer for PDFCreator generated the path to PDFSpool.exe using the mangled short filenames rather than long filenames - this is probably done for backwards compatibility with older versions of Windows that don't support long filenames, but I don't know.  I also don't know how or why it worked for the first day or so.  The problem is that "C:\\PROGRA~1\\" is ambiguous: it could mean "C:\\Program Files\\" or it could mean "C:\\Program Files (x64)\\", and apparently it reverted to pointing to the shorter option.  This is rank speculation on my part, of course: I haven't seen the installer code...

>> 2.) Why not simply deactivating UAC?

If you meant temporarily deactivating UAC... that requires two reboots (disable UAC, reboot; do your thing; re-enable UAC, reboot; go back to work); this method requires none - you don't even have to log out your session.

If you meant "why not disable UAC permanently"... well, yes you can do that, but it's not a great idea, security-wise.  The point of UAC is to limit the amount of damage that malware (or dumb users) can do; running as an administrator all the time is like taking the blade guard off your tablesaw - convenient, but not recommended.  It's just that Microsoft is a few decades late in embracing this philosophy, and we've all developed the habit of running as administrator all the time (and writing software that won't run any other way.)  Microsoft's first stab at doing things the right way - Vista - was a horrifying mess, and 7 is not perfect; still, the sooner we all get into good habits the safer we'll be in general.

>> This should be the easier way than activating a new user account that will create a new user profile.

We're not creating a new user.  "Administrator" and "Guest" are created when Windows is installed; they're just disabled by default.  You could also do this by creating a new administrative user, but this way is faster, easier, and (I think) cleaner.  Still a hack, but not such a nasty hack.

>> 3.) The properties of other printers can be modified. It seems that this does not work because it is non Microsoft Code.

Not true.  You can modify the properties of the PDFCreator printer as well (go ahead, try it!) - just not the properties of the "PDFCreator:" port monitor.  As far as I can tell, that's because the installer that created it was running as an administrator; whatever is created by an administrator can only be modified by an administrator.


I have the same problem I can see the job in the spooler but doesn't save it as the pdf file, and the temp folder is empty.

Uninstalling and reinstaling with or without the reboot doesn't help.Printer driver has the correct patch C:\\Program Files (x86)\\PDFCreator....

What I did was:

I restored installed and activated only win7-64 from the image, and PDFCreator was working fine after installing it.

Then I restored the same system with the drivers installed only (graphic card, scanner, printer etc) and the PDF Creator did not work after installation.

I wonder, is this a problem with PDF installed after the printer drivers (64bit epson vs. 32bit PDF) or because some of the windows futures was removed (Fax and Scanner, XPS, Internet Printing) and then PDF was installed.

OK I solved the problem. Path to the temp folder in enviromental variables for user was wrong I made the typo in (%SystemRoot%\\Temp). Works fine now.