Windows explorer crashing when right click


#1

Hi all,

After upgrading to the last PDFarchitect4 version (4.1.04.27684 64bits) i had some problems with windows explorer (on two computers under Windows 10 64bits, one home and one pro).

If i cut or copy a file in windows explorer, the next click shut down the explorer without a message instead of open the context menu. Never had a problem, computers have 16 GB ram, and that happen the same day i upgraded this program.

I found a fix (temporary ?) for avoid that, you need to use a program called Ccleaner.

Download and launch Ccleaner, select Tools then Launch and finally the tab Context menu. Look for the line with PDFarchitect4_managerext and uncheck it.

No more crashes


#2

I am also having this problem, where windows explorer will not permit a right click to copy or paste. However, Ccleaner did not fix the problem. Is there a way that you can download the previous version that behaved correctly? I’m trying to figure out what part of the program is causing this problem by only loading one module at a time. But this is proving difficult.


#3

Hi,

sorry for the trouble. I tried to reproduce this here but didn’t get any errors (also Win 10 Pro x64). PDFarchitect4_managerext sounds like it is related to the PDF Architect 4 Manager / Notification system.
It is possible to disable the directly inside the application by disabling the “notification system” in options->general.
We will try to find out what causes this, but first we need to somehow be able to reproduce it.
Does it happen for any file, or only for a certain file type?

Best regards,

Robin


#4

Thanks for the reply. The problem exhibits for any file type. It is the action of right-click to cut/copy and then going to the destination and when you right-click to bring up the menu to click paste, the pointer becomes a blue rotating circle, and then about 15 secs later windows explorer aborts with no error. It is interesting that not only does the windows explorer abort that is being used, but if any other windows explorer is open on any desktop, they also shutdown.

I am currently trying to see if this is an interaction with another program. But the problem started about three weeks ago on both the laptop and the desktop, so is not isolated to one machine.

I will try what you suggest and disable the notification system and will post any other details that I come across. I rely on the product very much and having it currently disabled is troublesome.

Thanks!

Jerry


#5

I am having the same sort of problem with pdfArchitect V4.

Running Windows 10 Pro 64-bit (V1511).

I had pdfCreator V2.2.2 installed and pdfArchitect was also
installed as part of the same download and all was working well.

Then pdfArchitect did an upgrade and shortly after I found
that in File Explorer :

  1. I could right click to copy any file type and
    paste the copy in any other folder, but

  2. If I right clicked on a file and selected Cut
    (to move the file) then I could navigate to a new folder but when I tried to
    paste in the new location, file explorer would crash and the tool bar at the
    bottom of the screen lost most of the icons and the start button would not
    work. After a considerable time the start button would resume and the icons
    came back to the task bar.

Yesterday, I did a refresh of Windows 10 Pro which removed
all application software from my PC.

Tested and the File Explorer right click functions were working
correctly. Gradually re-installed all my applications software.

Reinstalled the newer pdfCreator V2.2.3 along with the
latest pdfArcitect V4. Immediately I again had problems with the File Explorer
right click functions.

This time:

  1. even copying (Right click and Copy) would
    crash/shut-down the File Explorer and Windows 10 would go back to the Desktop
    or an internet page if Mozilla was operating.

  2. The task bar icons did not disappear and the start
    button did not stop working

I removed pdf Architect V4 entirely and the problem was resolved –in that
the File Explorer right click functions resumed correctly.


#6

I have the same problem with a customers machine, I hope they will deliver a fix for this now…


#7

Hi,

we haven’t been able to reproduce this on our Win 10 test machine, but as a workaround disabling the windows shell integration of the create module seems to get rid of the error. This can be disabled seperately by running the uninstaller and selecting “modify” on the second step. Then uncheck the windows shell integration under modules->create module and complete the wizard.

Best regards,

Robin


#8

Thanks for this. I was about to go bat crazy when I explorer kept crashing on right click. I disabled Windows integration for now and I am MUCH happier. Thanks for the work-around!


#9

Note this issue with PDF Architect 4 has been noted on the Microsoft support:

answers.microsoft.com/en-us/windows/forum/windows_10-performance/windows-10-file-explorer-crashes-explorerexe-with/d09df485-93f2-48a7-8ec2-d5b062056074

(New User, so I can’t post a real link)

My Windows 10 Error Log showed Explorer.exe crashed with support.dll in PDF Architect 4 as the “Faulting Module”, identical to what is shown in the link.


#10

Thanks for pointing this out, I have now replied there to offer a work arround. Did disabling the Windows Shell integration solve the problem for you?

Best regards,

Robin


#11

@Robin.W, I did disable the Windows Shell integration and so far, so good. But, I haven’t had much run time since the change.


#12

Hi @Robin.W, If You want to reproduce error or find something helping solve the problem for Win10-64 - just enable shell integration for PDFArchitect4_ManagerExt, run Management Console by right-click My Computer. Sometimes by now or everytime after second and next times of invoking MC - an error appears. This is from compmgmtlauncher.exe - pointig first time at support.dll, next ntdll.dll. Analyze logs for applications and system. Hope it will be helpfull. BTW after disabling shell integration of PDFArchitect4_ManagerExt error disappears. Regards Chris.


#13

Hi @xfazi,

unfortunately I have already tried this but it doesn’t crash my explorer or give any errors (even if I do it 5 times in a row).
So it must be related to additional conditions. Our developers are looking into it.

Best regards,

Robin


#14

Same issue here. Thought it was another program but with a lot of digging I figured the dll (support.dll) which is causing this problem is part of PDF Architect.

Name der fehlerhaften Anwendung: explorer.exe, Version: 10.0.10586.420, Zeitstempel: 0x574919b9
Name des fehlerhaften Moduls: support.dll_unloaded, Version: 4.1.4.27684, Zeitstempel: 0x572a0944
Ausnahmecode: 0xc0000005
Fehleroffset: 0x00000000000053c0
ID des fehlerhaften Prozesses: 0x22a8
Startzeit der fehlerhaften Anwendung: 0x01d1ce6cf42357a6
Pfad der fehlerhaften Anwendung: C:\WINDOWS\explorer.exe
Pfad des fehlerhaften Moduls: support.dll
Berichtskennung: 323ea28c-3757-4e24-9703-17a2ba944692
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:


#15

I have the same issue on a windows 10 64bit laptop. It crashes my system every time I go from the menu with your PDF options to the normal menu. Not totally but it force closes and reopens explorer.exe


#16

Hi,

does disabling the Windows Shell integration as indicated in the solution above resolve the problem for you?

Best regards,

Robin


#17

It seems like this solved the problem for me. Will report if something changes. Thank you so far.


#18

My 2 cents on a similar problem which I hope will help you solve the trouble:

I got crazy for 3 days with a brand new W10 installation from scratch on some 3 yrs PCs - and that happened on one of the same PCs, all identical hw pieces, using W8.1, but I didn’t care much 'cause I was going to upgade to W10 - on which I also installed Hyper-V to keep an old Windows XP installation, and Hyper-V uses a so called “virtual switch” to bind the physical netowrk card of the host to the virtual network card used by the VM (I configured it in “external” mode); I specify this becasue of a reason which will be clear later on in the explanation of the problem.

Well to make it as shortest as possible, after I’ve installed all of the drivers and basic sw tools and applications, liek Office 2013, I noticed that ALMOST each time I requested the “Manage” function from “This PC”, Windows would return a generic “software exception” error just before opening the “Computer Management” MMC panel, which after that would perfectly work, though. Unforetunately, the Windows LOGs would show some “ntdll.exe” error related to the summoning of “compmgmnt.exe”, and that was a pretty freaking enough warning realted to an unknown system trouble; after a few, but long, tries, I discovered that removing the Realtek ethernet driver pack (installed from the latest version available on Realtek’s site) would fix the trouble, so I thought it was a buggy driver “only”, even if I found no reference/evidence on the Internet about that, and in fact removing it from “installed programs” left me without network, after the first reboot, but everytthing else seemed fine… JUST that at the next reboot, W10 would find the driver again (usinf Windows Update) and install the network again, but even then things seemed fixed… UNTIL I reconfigured the HyperV’s VM vritual switch and the darn error pop-up again in its horrific style; I swear I got crazy for so many other hours, until I found for a total lucky chance this thread on your support site and, guess what, I HAD INSTALLED the latest version od PDF Creator which brings with it PDF Architect… uninstalling the latter indeed made me go back in peace with my freshly installed, cleaned and so polished updated installations… I could imagine everything but a sw like yours causing such a peculiar intercation with other system components of that kind (guys, it bothers NTDLL.EXE…!!!), but hey… IT’s made of this, right? :wink:

Ciao,

EMC.


#19

If I update PDF Architect that was previously installed on a Windows 10 the right click doesn’t have any issues. The issue is when we install PDF Architect as a fresh install it crashes Windows Explorer every time you right click on the Windows icon in the bottom left and go to Control Panel or any of the other options there. Is there an update coming soon? During the install it doesn’t give the option not to install the Windows Shell Integration so at this point we have to install the program and then go back in and remove the Windows Shell Integration which is a pain when we are trying to roll out Windows 10 computers to over 700 users.


#21

Windows crashing issue arises due to missing system file or outdated system drivers. So it is recommended to make sure that your system files are not missing and update the system drivers. For more you can also visit:
sites.google.com/site/fixwindowerror