PDFCreator 2.3.1 Terminal Server - No Printers created during install

After the install of PDFCreator Terminal Server (as “install” user via Admin CMD prompt) I receive the error:

“You do not have any PDFCreator Printers installed…”

I attempt to run the fix, but then receive the message:

“PDFCreator was not able to repair your printers…”

As per other forum post I attempted to delete the PDFCmon reg key and reboot, same results. I then used PrinterHelper and was provided the following error:

C:\Program Files\PDFCreator>PrinterHelper.exe /installprinter Create_PDF /portap
plication “C:\program files\PDFCreator\PDFCReator.exe”
Message = The specified module could not be found
Source = PrinterHelper
StackTrace = at pdfforge.PrinterHelper.Win32Printer.AddPdfcreatorPrinterMoni
tor(PrinterEnvironment printerEnvironment, String monitorName, String portName,
String monitorDriverFileName, String programFullFileName, Boolean server)
at pdfforge.PrinterHelper.Printer.InstallPrinter(IList1 printerNames, IWin32 Printer win32Printer, String monitorName, String portName, String portApplicatio n, String driverName, String externalPpdFile, Boolean server, ILogging logging) at pdfforge.PrinterHelper.Commands.CheckCommandInstallPrinterAndExecute(IDict ionary2 cmdlParams, IWin32Printer win32Printer, String monitorName, String port
Name, String driverName, ILogging logging)
at pdfforge.PrinterHelper.Program.Run(IDictionary`2 cmdlParams, ICommands com
mands, IWin32Printer win32Printer, ILogging logging)
at pdfforge.PrinterHelper.Program.Main(String[] args)
TargetSite = Void AddPdfcreatorPrinterMonitor(pdfforge.PrinterHelper.PrinterEnv
ironment, System.String, System.String, System.String, System.String, Boolean)"

Any assistance would be greatly appreciated.


just an initial guess, but it could help to restart the spooler prior to running the printerhelper.exe.
To restart the spooler, run
net stop spooler
net start spooler
from an elevated command line.
I will ask one of our developers to have a look at this, if restarting the spooler doesn’t solve the problem.
Was it a fresh install or was there an older version of PDFCreator installed on the server previously?

Best regards,


Thanks for the Reply Robin.

In response to your inqury:

I had attempted to start / stop the spooler with no luck.

We had initially attempted to install PDFCreator on the server, but the install failed advising us to acquire the Terminal Server version… which we did.

On the first run of the installer, PDF Architect installed and created a printer, PDFCreator did not. We removed PDF Architect and PDFCreator and attempted again without the PDF Architect component, but still no printer is created

FYI - This is when I found the forum posts relating the PDFCmon key

Bump for Review.

This is still and issue and was wondering if there was any solution.

Using installer: PDFCreator-Terminal-Server-2_3_2-Setup.exe

Hi, another user had the same issue and for him it was caused/solved by changing a system setting:

Please check if this could also be the issue for you.

Best regards,



I have the same issue, I am trying to install the newest version 2.4.1 and although the app is shown in C.Panel, when I search under Devices & Printers there is no PDF creator printer installed.

I tried on a virtual machine on which I previously had an older version of PDF creator and I ran first this command as an admin,of course ( Inavigated first to C:Program Files\PDF creator):
printerhelper.exe /uninstallprinter

Following error was shown: ‘printerhelper.exe’ is not recognized as an internal or external command,operable program or batch file.

I tried to solve this by modifying the path under Environment Variables and then rebooted, still no success

This was the path by default under System variables:

C:\ProgramData\Oracle\Java\javapath;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0;%systemroot%\System32\WindowsPowerShell\v1.0;%systemroot%\System32\WindowsPowerShell\v1.0;C:\Program Files\Common Files\ThinPrint\

I modified it by putting C:\Program Files\PDF Creator and left the others like they were.Not sure I modified it correctly. Could not find exactly the printerhelper.exe on my computer.

Also I tried to delete from registry entries related to printer PDF creator, but with no success and also stop/start spooler.

Not sure I modified it correctly. Or do you have other solutions to solve this issue?

Thank you very much for your help.


there might not habe been a printerhelper.exe on the VM if the installed version was old enough.
Does the setuplog.txt for the terminal server installation contain any errors?
On the terminal server where the current version is installed, the printerhelper.exe should be present in any case, so please try to run the commands there. If they aren’t run successfully, you should at least receive a more helpfull error message. Alternatively you could wait until next week and try with the new PDFCreaotr 2.5.0 which has an improved printer setup workflow.

Best regards,


Hi Robin,

Thank you for your assistance, will try the solution your proposed.

Have a nice day!