Problem with excel file and context menu "Create pdf editor"

Good morning at all,
I’ve a trouble with pdf creator.
I’ve a 3.2.0 release of pdf creator, installed on windows 10 and office 2016. My problem is when I click on the xsl or xslx file with right click, I choose “Convert with pdf creator”: now excel start, but it’s empty. Excel doesn’t show the file that I’ve selected and it doesn’t open PDF creator.
How can I do?

Thank you.

UP, please!
I need an help!


Excel unfortunately doesn’t register its “print to” command correctly (this is what PDFCreator looks up when you select “Convert xls with PDFCreator”). The easiest way to overcome the issue is to open the file in excel and print it to the virtual PDFCreator printer, which will automatically lauch the PDFCreator application and let you convert the file.

Best regards


Hi Robin, with version 2.5. * it worked properly …


did you by any chance install a new Exel Version?

I think the issue is new in Excel 2016.

Best regards


I’ve Office 2013.
I had try with pdf creator 2.2.2 - 2.3.0 - 2.5.3 and it works without problem.
If I use 3.2.0, I must open the excel document and after I must print with pdf creator.
I’ve tried in windows 7 and windows 10.

Now, in 2 different pc, if I use pdf creator version 2.*, I receive an error message, like this:

Error: taskcanceledexception .

The PDF are anyway created.


thank you for the additional information, but please let me ask just to be sure: Do you only get the issue for PDFCreator 3.2.0 in combination with office 2016 (in your first post you said you are using office 2016), or does the combination of office 2013 and PDFCreator 3.2.0 also not work at all on your machine(s)?
PDFCreator will check the “Default” registry entry for HKEY_CLASSES_ROOT\xsl (or xslx) and , lets say its Excel.DocumentXX then execute the command stored in HKEY_CLASSES_ROOT\Excel.DocumentXX\shell\print to\command. Which command is registered here on the machines where it isn’t working?
Does executing the command manually work?

Best regards


No, the issue is relative to pdf creator 3.2.0 . The last test that i had do, I did was with a pc windows 7 with office 2013 and pdf creator 3.2.0

Which kind of command I must search in this registry key?
I don’t have a command inside…

This command works on my machine with Office 2016:
"C:\Program Files (x86)\Microsoft Office\Root\Office16\EXCEL.EXE" /q "%1" /j "%2"
For Office2013 the command should most likely be
"C:\Program Files (x86)\Microsoft Office\Root\Office13\EXCEL.EXE" /q "%1" /j "%2"

ok, where I put this command for pdf creator key?
Thank you

The is no PDFCreator key or file type, you need to ensure the command is registered correctly for Excel, as described above.
This is only valid, if the (Standard) entry for xls is Excel.Sheet.8

and you might additionally need to modify the entries for e.g. Excel.Sheet.12 to make it work for xlsx, too.

Ok, i modified the registry key hkey_classes_root\excel.sheet.12 .
Now, with xlsx, excel open the document, but I receive this message:
“PDFCreator.xslx doesn’t not found. Verify that the file …”

Did you perhaps modify the “open” instead of the “print to” command?
Please post a screenshot of what you did, I gave your account the required permissions.

Thank you very much for the screenshot.
The command looks correct and is in the right place, I assume the two error messages from excel is what you get when you tried to convert a xlsx? Was the command already there, or did you create it yourself? I think the only thing that is not quite right and was a bit tricky to spot, the command is using the incorrect quotation marks (curly “” instead of straight"") around the “%1” and “%2” parameters. I assume you copied the command from this post and while I did also directly copy it from my registry, the forum software changed the quotation marks to make them better readable. Editing the command and manually replacing all double quotes " once should fix it.

Sorry for the trouble.

Ok, i've correct the entry in registry editor.
Now, it shows this problem:

Was the file you tried to convert called PDFCreator.xlsx and was it a valid xlsx file (renaming an xls to xlsx will not work)? Or was the file the Questionario.xlsx shown in the background?

The file that i've tried to convert is questionario.xlsx. I had click with the right on the excel file, i had choose "Convert with pdf creator" and I receive this message.

Ok, very strange. It sounds like it is swapping the parameters for the printer and file name, since PDFCreator is the name of the printer it is supposed to print to and not the name of the document. Is the command still in the right order as in the screenshot you posted earlier? What happens if you switch the /q and /j parameters with eachother?

same message…
Yes, the command is write in right order, like in screenshot
In an other PC with 2.5.3, the command works correctly